Why can't I play my own videos in my room!?

I made a room. I put a few songs in a playlist. I invited a friend in to test if the site works.

When I push play on a video, it plays for half a second and then stops. My friend can’t hear anything. The video only starts playing when THEY push play. After they do, THEN I have control over starting and stopping it. WHY!?

As if that’s not ridiculous enough, when I skipped to the end to see if it would autoplay correctly, it did just fine for them, and for me it showed the video stopped with the YouTube play button in the center, but the timer was counting down. So it doesn’t play on my end, but does on theirs.

What insane garbage is this!?

We’re both using firefox, latest version, on desktop Windows.

Thank you very much for your bug report. I heard of this behavior before from one user but so far i was not able to reproduce the issue. Two questions:

  • Are you the owner of the room? (Did you created it?)
  • Do you see the same behavior when you are opening the site in a private or incognito window? I ask because sometimes these kind of bugs are caused by browser extensions. In a private window most of them are disabled.

Thanks a lot for your help finding the cause of this issue.

Are you the owner of the room?


Do you see the same behavior when you are opening the site in a private or incognito window?

Haven’t tried that yet, but I did already do my best to turn off any kind of add-on that I could imagine causing it.

Just tried W2G in a private window. Still the same problems. :confused:

Thanks a lot. I just changed something. Could you do me a favor and clear your browser cache and try it again? Any difference?

It’s half fixed? I cleared the cache and restarted Firefox. I can push play on videos on my end and they don’t auto-stop themselves. But when it goes to the next song, it’s paused for me but the timer’s counting down.

Also, now we have a new weirdness. When I go to the site, it says my temporary room doesn’t exist and has been deleted. When I sign in, it shows me my temporary room with the playlist I made, so it’s obviously not deleted. :S

BTW, I do have the NoScript add-on. I have repeatedly temporary-whitelisted everything on the page. No difference.

Thanks for your feedback. When you enter a room, make sure to copy & share the link from the little box in the top right of the room. The link displayed the URL bar will be different when you are logged in or not.

Regarding the playlist. Do i understand you correctly that when it goes to the next song of the playlist the new video does not load at all? I’m not 100% sure what you mean with “timer is counting down”. Can you take a screenshot of that?

The video is not playing. You can see the YouTube play button right in the middle of the screen. But the video length timer is counting down as if it IS playing. And it was playing for my friend watching along, but not for me.

Thanks a lot! Does this happen as well when you click on an item in the playlist? Or only when it autoplays at the end of the previous video?

I ran several tests with different Firefox versions but were not able to reproduce this issue. Do you see the same behaviour with a different browser on your system?

Problem happens only on autoplay.

Thanks… i assume that somehow your browser prevents playback when the window is not focused or inactive for a while. If you have the chance you could try to reset your Firefox and try it with a fresh install. I assume it’s some setting or extension that causes this issue. I will continue to reproduce this issue but so far i had no luck with it.

I actually did a fresh install a few weeks ago. :confused: