W2G Not Requesting Permission

No matter what browser I am on (FFox, Chrome, even Waterfox), Watch2Gether will not request permission to access my cam/mic when I click the share video button. I can’t manually grant permission via settings either because the browsers require it to have asked first.
I have tested the feed on the test site recommended on other bug threads, and it shows up fine, but no matter what I change or enable/disable, nothing works on W2G.
Has anyone else encountered this and/or knows a fix?

Thanks a lot for your feedback. Are you 100% sure that you did not accidentally block cam / mic access for Watch2Gether? If not please run the test on this site and let me know if it reports any errors:


Thanks for the response, and sorry about the delay - have been trying all kinds of workarounds with other users that are already using a similar setup to what I’m creating.
In the end, I enabled stereo mix to capture my desktop audio and suddenly the option to select the inputs appeared when I clicked the button.

Cool does that mean everything works for you now?

In the end we couldn’t get audio to register through it as a group, despite it working during a 1-to-1 test. Opted to host the audio via direct voice link instead, and use W2G for only the image hosting.
We haven’t tried to optimise things further as we found a more direct (albeit ad-hoc) way of hosting our videos peer-to-peer without needing a secondary website, but thanks again for the responses, as trying to get W2G working led to those discoveries.