Soundcloud Playlists not synchronizing correctly

When I add Soundcloud Playlists to the Queue and try to skip tracks within the Soundcloud playlist, everybody (except for me) gets to listen to the same song again. Is there any way to fix this?

Thanks for bringing this to my attention. I wasn’t aware that its even possible to play Souncloud playlists in the embedded player. So you found a non existing feature :slight_smile: But as you have seen the sync is not working in this case. I have therefore made the following changes:

  • You can no longer paste links to SC playlists and play them directly
  • BUT: You can now import SC playlists into a Watch2Gether playlist. Before this was only possible for Youtube playlist.

To import a playlist, click on the settings icon next to the playlist selector on Watch2Gether. in the dialog that opens up you find the option to import playlists.

Hope this helps!

1 Like

Thank you for your incredibly fast help and fix, you’re awesome!

One more thing:slight_smile:
The next track won’t play if you dont have the tab of watch2gether itself open. It would be really nice to have them automatically play even when the tab is not opened.

Yes… this is a Chrome “Feature” which should prevent annoying audio from auto playing in background tabs. I found a fix for Youtube but Soundcloud tracks are treated as “new” audio when they are loaded and can therefore not auto play when the tab is in the background. You have two options:

  • Open Watch2Gether in its own window instead of a new tab. Autoplay should work then even when the window is in the background.
  • Use Firefox which does not have this feature.

Hope this helps!

Florian

2 Likes