"Oops, you appear to be offline, this app requires an internet connection."

I can’t use watch2gether with my wifi because I appear offline but if I go with another internet convention I appear online.
I tried to clear the cache and cookies but nothing.

I have the same problem, how can we fix it?

Hey, where are you located? Can you open a windows terminal window (‘cmd’) and enter the following two commands (one after another)

ping www.watch2gether.com


What is the output of these commands?

it is not recognized as an internal or external command,
an executable program or batch file.
This is the output, and i’m located in Italy

Did you try to do it this way?


The commands i mentioned have to be used one after another not together.

Ok, this is the output:
C:\Users\utente>ping www.watch2gether.com
Impossibile trovare l’host www.watch2gether.com. Verificare che il nome sia corretto e riprovare.


Esecuzione di Ping con 32 byte di dati:
Risposta da byte=32 durata=85ms TTL=49
Risposta da byte=32 durata=67ms TTL=49
Risposta da byte=32 durata=102ms TTL=49
Risposta da byte=32 durata=116ms TTL=49

Statistiche Ping per
Pacchetti: Trasmessi = 4, Ricevuti = 4,
Persi = 0 (0% persi),
Tempo approssimativo percorsi andata/ritorno in millisecondi:
Minimo = 67ms, Massimo = 116ms, Medio = 92ms

Thanks a lot… the first error message is the problem. Are you connected through a mobile network or a landline?

I’m connected through a mobile network

Thank you… there seems to be an issue with the Name Resolution (DNS) with your provider. The site itself is working fine but your system is not able to resolve the name www.watch2gether.com into the related IP address. As a workaround you can try to reconfigure your system to use a public DNS server such as from Google. But this is more for experienced users. I’ll try to resolve the issue from my site as well.

I have solved the problem, thankss

How did you solve it?

I changed my DNS with, as you told me and it worked

Alright, thank you. Just one more question: During the whole time you had no problems to access https://community.watch2gether.com/ , right?

no, I have got no problem

Alright, thanks for your help debugging this!