I cannot connect with others in my Watch2Gether room

Hello everyone/admins!
I’ve been happily using the platform for about 18 months, to teach simultaneous interpreting. However, for the last month or so I have been unable to use the platform at all - each time I try to connect with another person in my room, their thumbnail goes green and the loudspeaker icon comes up, but they cannot see or hear me, and I cannot see or hear them!
Everything else, including my playlists, seems perfectly normal, and I can play videos as per normal

1 Like

Hi! Which browser are you using?

Thanks, Florian! I’m using Firefox - always have done…

Hi Chris, i just tested the system and generally it works fine with Firefox. When you enable your cam, do you see your own video? A couple of things you can look into:

  • Try to disable your browser extensions one by one and check if that makes a difference.
  • Try a different browser on your system (Chrome for example)
  • Disable any VPN solution on your system (if any)
  • Try to run this test and check if it reports any errors: Webcasts.com WebRTC Test


Thanks for the helpful suggestions! I just tried using Chrome, with exactly the same result. I did a test, and the other party and I can both see and hear videos, and can both change which video from my playlists is playing - but we can neither see nor hear each other.

Another thing I’ve noticed since the platform stopped working, is that when I see the icons for the other people connected, there is a white ‘play’ arrow in a white circle superimposed in the middle of the icon - that was never the case when the platform worked for me…

I also just tried to use the test site you sent (thanks!), but couldn’t get the site to respond from its landing page. However, I do know that my computer’s speakers, webcam and mike are working fine, as I use them a lot on Zoom…

Can you try to run the site in a Chrome incognito window? Does that make a difference? It’s most likely not an issue with your hardware.

Hi! Tried that - exactly the same result…

Thanks for the update. Can you take two screenshots for me after you and someone else in the room tried to enable cams:

  • One of the room itself
  • One of the browser console. Right click on the page and select “Inspect”. In the dialog that opens up make sure the “Console” tab is activated.

Please send both screenshots to florian@watch2gether.com - It should help me to figure out the cause if the issue,