Camera disables itself after ~1s on mobile

When attempting to start camera on mobile it will work for about 1s and then disable itself again. The fix is to open the camera select menu and choose one, even if there’s only one option.

Thanks for your feedback! What kind of device are you using? Android or iOS? Which browser? Thanks a lot!

same issue here - stream turns off after one second on macbook or iphone 11 using safari

Thanks… stream turns off means that the video becomes just a dark black square?

no, I mean it turns off completely as if u never enabled it. Also the advice to select devices again from the dropdown menu did not work for me/us :frowning:

Thanks… do you see any error message when it disables or does the green icon simply turn dark again?

it just turns dark again - same goes for the micro when using safari. It works with Chrome on the same device but the voice quality is poor so we would love to make it work on safari again.

Also if he is using headphones the microphone works properly but since we are in the room for the entire day its not reliable to use headphones all the time (for usual we just use the onboard speakers). So far we did reset website preferences, Cookies and the mic itself. Also we tested the microphone on other websites with safari and it did work as usual - by the way the settings we used worked just fine for like 6 months the issue just came up last week.

Yes, it toggles off again as if it had been clicked.

Thanks a lot for your input. I rolled out some fixes for the cam system today. Could you have a look and let me know if you still see this issue?

appreciate your efforts but its still not working for us : / same with microphone

Do you know which version of iOS is installed on that device?

both devices got the latest iOS Update

Hi, some of my friends seems to have the same issue. Unfortunately, I am unable to reproduce the problem on my own iphone.
I am on iOS 15.2, it works on Chrome and Safari
My friends are on iOS 15.1 and they have this issue, I don’t think it’s related
We have the same Camera settings…

Basically, the camera turns on and turns off a second after, as if he did not active it. He has the “Allow / Not allow” only the first time that he launches his app (it can be launched from Discord, Messenger, Safari or Chrome).

I wish I could help more than that T_T

Thanks a lot. I ran some tests with an iOS 15.2 device and were not able to reproduce the issue. I doubt that iOS 15.1 is any different but it might be worth a try. After the camera disables do your friends see an error message popping up saying something like “Device could not be activated”?

Hi, they don’t have any error message. However, I asked them again about the “Allow / Don’t allow” popup and it shows up every time that they try to turn on the camera.

Also, it is not specific to iOS. One of them has a Samsung S8

I’m still trying to reproduce this issue. No Luck so far. I’ll keep you updated if i can figure something out.

Hi, we noticed that the microphone keeps working when you rightclick the microphone icon right after you enabled it. The rightclick triggers a browser menu and as long as the context menu is open the mic works - its not really practicable since u can not use the mouse in that time so just a side note

Thanks for your input. You are talking about a desktop system here, right? If i understood your previous post correctly you had initially a problem with a phone?


yes im talking about a MacBook in this scenario. Got the issue on mobile and desktop : /

Strange… i tried to reproduce this with iPhone but had no luck. Do you see the same behavior when you open the site in an incognito window?