Won't load?

no matter how long i wait watch2gether wont work. Its not my account because i can use it on other devices just not my computer. It will let me into the room but it doesnt load, like it has the loading symbol in the middle and the screen is darkened. ive tried resetting my computer it just wont work

Thanks for your feedback. A couple of questions… Which browser are you using on your computer? Does it work if you try a different browser? Did you try to delete the Cache and History? Do you have an adblocker installed on your computer?

I have the exact same issue. the search part of watch2gether wont load, so I cant put up videos at all, and everything around the video window turns darker like its loading.

I’m using chrome, and deleting history and cached files yielded nothing.

Can anyone help me on this? I really like to use watch2gether, and I’ve never had this issue before.

Do you have any extensions such as adblockers, userscripts… installed? If yes, try to disable them and see if that makes a difference.

Same issue here… I use google chrome, cleared browsing history and cookies, disabled all extensions and still doesn’t work. Other people can watch videos in my room, but i can’t use any because videos won’t load. Sometimes the video start, where i am the only one its playing for. When that happens i can pause/start the video, but can not choose what part of the video i want to watch.

so basically i can’t watch together, and barely alone

You might be affected by this issue. Please have a look:

Issues with Popper Blocker Browser Extension

Thanks mate !

Disabling the extensions wasn’t enough. White listing W2G on poper blocker solved it :smile:

I’m glad it’s working for you now!