Webcam not working

I cannot seem to have the webcam work anymore. Until yesterday, opening the webcam was working fine. Today, I couldn’t get it to work anymore after many tests.

I tried updating my browser to the latest version (firefox); there were no hardware changes or network changes as well. I am using a laptop and the webrts technology is properly working everywhere else besides this website.

Checking the console, I get these errors when opening the webcam:

navigator.getUserMedia has been replaced by navigator.mediaDevices.getUserMedia
RTCIceServer.url is deprecated! Use urls instead.
onaddstream is deprecated! Use peerConnection.ontrack instead.
MediaStream.stop() is deprecated and will soon be removed. Use MediaStreamTrack.stop() instead.

Any suggestions in how to make the webcam work again?

Much appreciated!

Hi! Thanks for reporting this. Can you give me the exact version number of your Firefox browser? And which operating system are you using?

I am using Firefox 52.0 64-bit and the operating system is a Windows 8.1 64-bit.

Thanks for the details. I tried to reproduce your issue with Firefox 52 on Linux but everything worked fine for me. Just rolled out a a fix that might have an influence in your case, but im not 100% sure. Can you delete your browser cache and try it again?

If its still failing:

  • “Does not work” means that you can not see you own video or you can see your own video but others in the Watch2Gether room can’t?
  • If you can’t see your own video: Do you see the pop-up from Firefox asking for permission to share your audio / video?
  • Did you try to use the site with Chrome on the same laptop and do you experience the same issue there?

Okay, so it seems it’s still not working after clearing the cache again… :frowning:

Does not work implies the fact that the image never updates, neither I or anybody else can see it (I see my normal avatar, they see a circle rotating forever).
Permissions: always granted them, tried all the possible orders to make it work properly.
Chrome: just tried on it, seems that here it works perfectly fine!

Thanks for trying again. Just for clarification: when you enable the cam in Firefox you immediately see the popup asking for the permissions?

I have it allowed permanently on the website, I can see the two icons for the camera and microphone on top of it. I can also see the webcam light turning on, but nothing on the website.

Ok, thank you. I will try to find a windows 8.1 machine to reproduce the error. The only advise i can give you in the meantime is to reset the permissions to “always ask” as described here, and see if that helps:

And… can you verify that you can see your webcam image on this site:

Thanks once more for your detailed feedback!

Hello once again,

I tried that website and all worked well - the issue on the website still exists on Firefox. I am currently using Chrome as a solution for the webcam, so don’t worry about it and thank you for the platform.

Have a nice day!